Jump to content


Photo

3rd generation bh5

Mechanism in back of bh5

  • Please log in to reply
128 replies to this topic

#21 LukeFranky

LukeFranky

    Regular Member

  • Members
  • PipPipPip
  • 578 posts
  • Gender:Male
  • Location:Armidale, NSW

Posted 11 October 2016 - 08:05 PM

I remember getting the part number BKR6EIX from a parts database somewhere along the way. Been using them a while. I haven't had any isues with them yet.

The B4 Bomber - 2002 MY03 Subaru Liberty B4, ADM, Manual, EJ208. 


#22 Jimbo

Jimbo

    Livin' the Legacy

  • Members
  • PipPipPip
  • 2,770 posts
  • Gender:Male
  • Location:B'town

Posted 12 October 2016 - 08:19 AM

I think PFR6B is just the normal unit, off the top of my head

'04 Liberty GT Premium "The Sprog Chariot"


#23 LukeFranky

LukeFranky

    Regular Member

  • Members
  • PipPipPip
  • 578 posts
  • Gender:Male
  • Location:Armidale, NSW

Posted 18 October 2016 - 06:00 PM

Luke -- used ones are all over yahoo JP and similar: try here for starters
 
Pretty cheap (but you'll pay in shipping).
 
Have been thinking about one as the basis for an alloy sump guard, myself - but worried about how low they hang.
 
Anyone have anything definitive about how effective / noticeable they are?


I bought one off that site. Thanks.

Took less than an hour to install. Noticed the difference just leaving the driveway. It's hard to explain. The steering feels stiffer but more responsive. Less body roll and feels planted.

You certainly don't need to worry about how low they hang, but won't protect your sump, unless by sump you mean gearbox.

The B4 Bomber - 2002 MY03 Subaru Liberty B4, ADM, Manual, EJ208. 


#24 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 19 October 2016 - 12:11 PM

Nice Luke. I,m glad you like it.



Sent from my iPad using Tapatalk

#25 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 19 October 2016 - 12:21 PM

I was introduce to water meth injection today and I was sold on it. But I would really like to get my car working before I install any upgrades.
I'm getting 11 psi on primary turbo and 5-7psi on the secondary turbo.
And everybody is telling me to convert to single turbo and they can source the conversion for me. But I'm sure if I persist on this I will be happy with 16psi stock and then tune to 20psi with the the water meth to keep things cool.
I'm really getting tired of trying and changes things/parts to see if it work.

Does any one can tell me via a diagram where the possible leaks could be?
As I said before when I put on the pressure test (blocking the intake)it goes up to about 5psi and I here air escaping on the secondary turbo side but can't find it



Sent from my iPad using Tapatalk

#26 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 20 October 2016 - 09:31 AM

I change all the hoses in the BBOD today and I think I'm hearing the Bov. Weird.....but no full boost as yet.
Will change the hoses in the engine bay and see what happens next


Sent from my iPad using Tapatalk

#27 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 26 October 2016 - 10:23 PM

So I change most of them, not all, inspect the other and clean them up.
Finally getting somewhere.
I saw a YouTube channel where this guy showed a different way to connect the hose to his fog machine. And I was like what!!!
I immediately went outside and attempt what he did and voila.............it work.....it actually work......I was so happy when I see smoke on the left side of the engine bay. Yeah believe it happy to see a crack in a hose I was a chasing for a year.
It was actually 2hoses
The hose from the brake booster that going in the throttle body and the hose form the Bov going to the solenoid was actually snap off(apparently it was under the bracket so you couldn't see it until you actually remove the Bov piping going back to the intake.
I already had piping and barbs to replace the one coming from the Bov
But the bigger one from the brake booster I have to go and buy.

Took it for or drive last night and felt the secondary turbo come more steady with out the fluttering and it move from 4psi to now 8psi
So.......so far I'm getting 11psi primary and 8psi secondary



Sent from my iPad using Tapatalk

#28 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 26 October 2016 - 10:31 PM

Oh I did that hose 10 mod where I run a line from one the Bov to the body and block of the one going to the solenoid
This was how the car behave with my leaking boost
1st gear flutter at the 4-5psi
2nd gear flutter again at 4-5psi all on the primary turbo (instead of going up tho the 11psi that I was getting)
However 3rd gear pull psi went straight up to 16psi. It didn't break my neck, it was a gradual pull but I have never seen 16psi with this car.
I put it back stock until I get the car functioning properly...

My friend has a wrx wagon and he told me when you went straight pipe exhaust no cat. His car move from 14psi to 16psi and it didn't went back since.

So I assume since I gone straight pipe that why my car went to 16psi and not 14psi. Don't know.
But the boost leak search continues


Sent from my iPad using Tapatalk

#29 LukeFranky

LukeFranky

    Regular Member

  • Members
  • PipPipPip
  • 578 posts
  • Gender:Male
  • Location:Armidale, NSW

Posted 27 October 2016 - 08:02 AM

Once you fix all those air leaks, reset the ECU. I think you might be surprised how well it runs after that.


The B4 Bomber - 2002 MY03 Subaru Liberty B4, ADM, Manual, EJ208. 


#30 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 27 October 2016 - 09:02 AM

I install a grounding kit this evening, replace the brake booster hose that was crack. Rest the ecu and still no higher boost.
Will do another smoke test and see what happens


Sent from my iPhone using Tapatalk

#31 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 27 October 2016 - 10:16 PM

Took it for a spin last night and something went wrong that the ecu did not like. It throw a code P1241.
And you see that code, a nightmare
Smh


Sent from my iPhone using Tapatalk

#32 LukeFranky

LukeFranky

    Regular Member

  • Members
  • PipPipPip
  • 578 posts
  • Gender:Male
  • Location:Armidale, NSW

Posted 28 October 2016 - 08:44 AM

Have you read this:

http://www.subyclub....-b4-code-p1241/

 

I got P1241 when my primary turbo had seized. It could have been triggered by the low boost on primary.

 

Does the car make any funny sounds, like air escaping?

 

Have you checked the little restrictor pill is still in the primary wastegate vacuum hose? It's a little metal thing inserted inside the hose.


The B4 Bomber - 2002 MY03 Subaru Liberty B4, ADM, Manual, EJ208. 


#33 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 29 October 2016 - 09:56 AM

Yeah I check. The pill is there and I clean it out. Check those same hoses and they are good. Thanks Luke


Sent from my iPad using Tapatalk

#34 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 29 October 2016 - 10:00 AM

Attached File  IMG_0556.JPG   167.08KB   10 downloads
Saw this on a website but mines not in this same order!
Doesn't it matter what order them in?
How is you guys line plum?


Sent from my iPad using Tapatalk

#35 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 29 October 2016 - 10:15 AM

Attached File  IMG_0559.JPG   764.23KB   10 downloads

Brand new linkage shot to hell. Only about a month old. Was told they fit 2003 Subaru but they were way shorter than the ones that came of the car which I think was not even original to begin with. I took the old ones to the shop and they match linkages from a Toyota Corolla ae110/ae111.
Can anyone send me a link to the original ones please. Thanks in advance

#36 LukeFranky

LukeFranky

    Regular Member

  • Members
  • PipPipPip
  • 578 posts
  • Gender:Male
  • Location:Armidale, NSW

Posted 29 October 2016 - 04:11 PM

Try Febest or Partsouq.

The B4 Bomber - 2002 MY03 Subaru Liberty B4, ADM, Manual, EJ208. 


#37 LukeFranky

LukeFranky

    Regular Member

  • Members
  • PipPipPip
  • 578 posts
  • Gender:Male
  • Location:Armidale, NSW

Posted 29 October 2016 - 04:13 PM

Oh, and that sway bar doesn't look original.

The B4 Bomber - 2002 MY03 Subaru Liberty B4, ADM, Manual, EJ208. 


#38 LukeFranky

LukeFranky

    Regular Member

  • Members
  • PipPipPip
  • 578 posts
  • Gender:Male
  • Location:Armidale, NSW

Posted 29 October 2016 - 04:42 PM

Looking at that photo of your intercooler, the seal doesn't look tight. Are you sure it's not leaking boost there?

The order of those hoses doesn't matter.

The B4 Bomber - 2002 MY03 Subaru Liberty B4, ADM, Manual, EJ208. 


#39 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 30 October 2016 - 01:20 PM

Looking at that photo of your intercooler, the seal doesn't look tight. Are you sure it's not leaking boost there?

The order of those hoses doesn't matter.


That's not my intercooler. I saw that online and copied it to see if That's the way it should be because mines plum wrong but as you said it does matter.


Sent from my iPad using Tapatalk

#40 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 142 posts
  • Gender:Male

Posted 30 October 2016 - 01:26 PM

Oh, and that sway bar doesn't look original.


That's probably why the original linkages were to short and break. Well I will clean the bar and see if I can a get name on it. Thanks




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users