Jump to content


Photo

2002 b4 no power steering


  • Please log in to reply
8 replies to this topic

#1 Dylan720

Dylan720

    Trusted Member

  • Members
  • PipPip
  • 147 posts

Posted 01 May 2018 - 10:13 PM

Hi all as from ny other post ive had some ussues latley with my b4 but have all been fixed but now power steering has gone i have replaced my power steering pump/fluid and still no power steering has anyone else has this problem and might know what i can check to fix thanks.

#2 duncanm

duncanm

    wha' who ?

  • Members
  • PipPipPip
  • 1,860 posts
  • Gender:Male
  • Location:Sydney

Posted 01 May 2018 - 10:58 PM

what, with a few more specifics please, is the problem?

 

Does the little power steering light on the dash stay on, showing a failure?

 

Do you have zero power assist?

 

Did you unplug something to do with the PS when you were rooting around with the manifold?



#3 Dylan720

Dylan720

    Trusted Member

  • Members
  • PipPip
  • 147 posts

Posted 01 May 2018 - 11:06 PM

No light on the dash what so ever everything is plugged in it was working but really noisy so i swapped the pump over today and its not working at all now but this pump works in my other suby thats just unregistered at the moment but its the exaft same pump as the one that was in it

#4 Dylan720

Dylan720

    Trusted Member

  • Members
  • PipPip
  • 147 posts

Posted 03 May 2018 - 11:26 PM

So ive done some reserch and it said to put the front of the car in the air and turn the steering wheel left to right and keep an eye on the reservoir to make sure it doesnt empty i moved it side to side 25 times each side and it hasent gone down at all i then started the car and done it another 15 times and it still hasent gone down at all when its up in the air the steering is light all seems good but when its on the ground its really hard to move and theres no power steering. Does that seem right how i bled it or is there more to it then that also is someone able to tell me what that black plug does at the back just wanna make sure ive done everything properly. Thanks

#5 duncanm

duncanm

    wha' who ?

  • Members
  • PipPipPip
  • 1,860 posts
  • Gender:Male
  • Location:Sydney

Posted 05 May 2018 - 09:44 AM

Your bleed method is ok - you don't really need to jack the car up, just cycle the rack lock to lock a few times and it should do the job.  The pump should make some groaning noises as the air is bled through. Keep cycling till the noises go away. 

 

If you didn't get any noises.. sounds like there's no fluid being pumped through.  Ensure the connections are all ok (eg: you didn't forget an O-ring or something), otherwise it may just be sucking air.

 

Plug at the back is for a fluid pressure sensor I think - which kicks off the warning light if pressure is low.



#6 Dylan720

Dylan720

    Trusted Member

  • Members
  • PipPip
  • 147 posts

Posted 05 May 2018 - 04:09 PM

Ok thanks for that no all o rings ar in place just one more thing does the lid have an o ring or some sore of rubber in it mine dont and if i put my finger in the whole of the reservoir and have someone turn the steering wheel the power steering works but if i just have the lid on it dont work have to comepletly block the whole for it to work

#7 duncanm

duncanm

    wha' who ?

  • Members
  • PipPipPip
  • 1,860 posts
  • Gender:Male
  • Location:Sydney

Posted 05 May 2018 - 05:44 PM

line on that side of the rack and reservoir are not pressurized ... maybe the rack is fubar ?



#8 Dylan720

Dylan720

    Trusted Member

  • Members
  • PipPip
  • 147 posts

Posted 05 May 2018 - 06:23 PM

Ok thanks ill have to look into the rack then

#9 Dylan720

Dylan720

    Trusted Member

  • Members
  • PipPip
  • 147 posts

Posted 05 May 2018 - 08:10 PM

So i went out and tried a few different things if i take the top house of that leads from the reservoir to the top of the pump if i take it off from the pump and put turn the steering wheel with engine running no fluid comes out but if i put my finger inside the reservoir hole where the lid goes and have someone turn the steering wheel fluid comes out not sure If thats normal i have tried leaving the lid on and turning the steering wheel and nothing comes out aswell




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users