Jump to content


Photo

Subaru B4 Turbo blown :( Please help


  • Please log in to reply
28 replies to this topic

#21 KONG

KONG

    Special needs monkey

  • Members
  • PipPipPip
  • 11,294 posts
  • Gender:Male
  • Location:Cental Coast
  • Interests:The 6 B's
    Beer, Bewbs, BBQ's, Beach, Boosting.

Posted 16 March 2018 - 05:23 AM

What line does your boost gauge run off?

#22 libertyB4andafter

libertyB4andafter

    New Member

  • Members
  • Pip
  • 6 posts

Posted 21 March 2018 - 02:11 PM

Update: so I took line 1 off and could hear the hissing of stored vacuum so that's a plus.
I have wound in my BOV spring all the way. Taken the intercooler off again and checked all lines and pipes and everything seems normal. I adjusted the ECV loosened until I could hear it chatter and then tightened two full turns. Took for a drive and still getting p1242 when building revs in the low range (primary turbo not boosting I suspect) and the boost gauge tells me I have around 0-2 psi and when the secondary comes on late I get full boost but then experience boost cut. Any ideas? Maybe the ECV is still opened??

#23 libertyB4andafter

libertyB4andafter

    New Member

  • Members
  • Pip
  • 6 posts

Posted 21 March 2018 - 02:49 PM

Also my boost gauge is T'd off from the BOV vac hose.

#24 libertyB4andafter

libertyB4andafter

    New Member

  • Members
  • Pip
  • 6 posts

Posted 27 March 2018 - 04:08 PM

So I fixed my problem. This is for anyone that might experience this in the near future.
It turned out to be the ECV. I had to fully reset the adjustment by taking the adjustment nut right off and starting from scratch. I set it roughly a turn past chattering and now I have full boost back and no ECV rattle in the lower gears. no more P1241. Happy days

#25 Doddyz

Doddyz

    New Member

  • Members
  • Pip
  • 25 posts

Posted 30 March 2018 - 09:29 AM

Luke Franky No I didn't replace the ecv with a new one didn't need too.

KOng yes I erased the cel code and hasnt come up since. Yes my boost has been restored since replacing my turbo with the leaking ecv  :)



#26 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 148 posts
  • Gender:Male

Posted 09 July 2018 - 12:19 AM

So the ecv is the one on the secondary turbo that's needs the attention?
Does the primary one has one as well?


Sent from my iPad using Tapatalk

#27 Doddyz

Doddyz

    New Member

  • Members
  • Pip
  • 25 posts

Posted 18 July 2018 - 05:18 PM

No the Primary turbo has a internal wastegate.



#28 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 148 posts
  • Gender:Male

Posted 22 July 2018 - 10:27 PM

I did the adjustments on the ecv and now I'm hearing the relief valve for the first time. However the car goes up to 4-5 psi of boost. What else can I do? Could it be the primary turbo?


Sent from my iPad using Tapatalk

#29 Arfreedom

Arfreedom

    Trusted Member

  • Members
  • PipPip
  • 148 posts
  • Gender:Male

Posted 23 July 2018 - 12:37 AM

Apparently I am missing that 2.0mm pill going to the Bov. Will see if I can source that. I've been trying with this car for so long now.


Sent from my iPad using Tapatalk




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users