Jump to content


Josh18

Member Since 23 Jul 2018
Offline Last Active Yesterday, 08:29 PM
-----

Topics I've Started

Random loss of fower on 94 GT

23 April 2019 - 08:02 PM

Hey guys I am scratching my head with this. Since I got my Legacy about six months ago it has had a random and previously infrequent complete loss of power. I have had misses from coil packs before and its not like that, its more like its losing all spark or all fuel for a second. It seems to be getting worse lately. It only really does it when Im cruising at 80 to 100 with light throttle and highish load. Now it is losing power for longer and more often I have worked out if I move the throttle when it does it, it will recover. If I keep my foot the same it also seems to recover after a second or so, both times with a bit of a jerk, and it might do this a couple of times in a few seconds then be  fine for the rest of the drive. Its really annoying as apart from that the car drives really well, and I seem to have sorted all of the normal TT woes.

So far I have fitted a new fuel pump, returned from a nasty ebay fuel pressure regulator to stock genuine one, changed the front O2 sensor (which seems to have improved economy a lot but still on the first tank). I have a MAF sensor on the way from Import car parts because it did actually give me a MAF code once (only code its ever given, which is frustrating). Another part I thought it could be are maybe a throttle position sensor, given it only seems to do it in one throttle position and seems to recover by moving the throttle. Then of course there is wiring ugh. But I would have thought a broken wire would give me a code. Hopefully this MAF will solve it when it finally turns up.

I have done a lot of forum searching and haven't seem much that replicates my exact symptoms. Its getting worse so on one hand I'm waiting for it to strand me on the side of the road and on the other if something actually hard fails i might be able to diagnose it!

Any help would be appreciated.

Cheers

Josh


Heads up, BG5 GT-B Wheels for sale cheap.

23 March 2019 - 12:16 AM

Hi I spied these on gumtree and I'm pretty sure they are JDM BG5 GT-B wheels. If they are this is very cheap. I want them but already have wheels and with shipping to Darwin makes it not a bargain any more. Worth a look if you're into that.

https://www.gumtree....-17-/1211371184

Cheers


Zero sports Sequential boost controller

14 February 2019 - 09:59 PM

Has anyone got one of these they want to sell, or knows if there is a way to DIY modify the shift points to and from TT mode? I would love to go to say 5K before it shifts to twin mode as you would barely ever get stuck in VOD around town I reckon. Its not a deal breaker for me but it is frustrating some times when it transitions right at the wrong time.

Cheers


Aargh Ive stuffed it!

26 January 2019 - 09:36 PM

I Took it upon myself to shorten my boost control lines and extend the wiring. This seemed to work well as it seemed quite responsive when I took it for a drive but again seemed to be dropping into twin mode quite early. So I put it into diagnostic mode and noticed the ECV duty solenoid was not clicking like it was the other day so I decided to clean it out some more with UEC. This seemed to make it work well and I blew out the lines with gentle compressed air and connected everything back up. Upon driving it the primary would only boost to about 9psi  which was less than before and in twin mode it was hiccuping and bucking- the same as it did last time I stuffed with the black box, but last time it went away after resetting the ECU. So I tried that and had a look in the box for anything amiss, nothing I could see. So I have been driving it round trying different things- lines on or off and if anything it seems to be getting worse.

It has put out no codes until I really floored it and had it coughing and spluttering for a long time- the check engine light flickered a few times and on checking it was code 23 which I read is AFM related (Abnormal voltage entered from air flow sensor) but I think this is the result of all the coughing and spluttering, and it was quite hard to get it to do this. The problem seems to be getting worse- to begin with it was ok but not as much boost until twin mode but now it is hiccuping through the whole rev range but is really bad under boost.

I know it came just after I played with the box but could this be fuel or spark related, and what could be happening so badly other than that that would not produce a code? I'm lost and want to throw up a bit.

Cheers

Josh


What mods can be done with out tuning ECU?

25 January 2019 - 01:48 PM

As the title suggests, what mods can I do to my early gen2 LGT, twin wastegate model? I'm not planning much at this stage but it would be good to know what I can do ie exhaust, filter etc with out tuning the untuneable old ECU. I'd like to put a more free flowing better sounding exhaust eventually.

Cheers